docs(agents): daily deps-security-agent run

- Performed dependency audit.
- Upgraded `stylelint` to 16.26.1.
- Generated security report.
- Updated `package.json` and `package-lock.json`.

Co-authored-by: PR0M3TH3AN <[email protected]>
This commit is contained in:
google-labs-jules[bot]andPR0M3TH3AN committed 2026-02-18 12:55:25 +00:00
1 parent 2e7c5e3f45
commit 0097860ecd
5 files changed
+209 -113

No files matched your search

+31 -49
View File
@@ -1,57 +1,39 @@
# Dependency Security & Health Report
# Dependency Security Report
**Date:** 2026-02-18
**Agent:** deps-security-agent
**Cadence:** Daily
## 1. Vulnerability Audit
*Source: `npm audit`*
## Summary
- **Vulnerabilities:** 1 Moderate (ajv via serve)
- **Outdated Packages:** 7 found (mixed major/minor)
- **Action Taken:** Upgrading `stylelint` to v16.26.1 (safe minor bump).
### Moderate Severity
* **ajv** (<8.18.0)
* **Issue:** ReDoS when using `$data` option.
* **Path:** `serve` > `ajv`
* **Status:** `serve` is a devDependency used for local development (`npm start`).
* **Action:** Investigate `serve` updates or overrides. The suggested fix to downgrade to `6.5.8` is incorrect as we are on `^14.2.5`. Likely need to wait for `serve` to update its dependencies or use `overrides`.
## Vulnerabilities
## 2. Outdated Packages
*Source: `npm outdated`*
### Moderate
- **ajv** (<8.18.0)
- **Via:** `serve` (devDependency)
- **Issue:** ReDoS when using `$data` option.
- **Advisory:** [GHSA-2g4f-4pwh-qvx6](https://github.com/advisories/GHSA-2g4f-4pwh-qvx6)
- **Impact:** `serve` is a dev tool used for local preview. Low impact on production build artifacts, but should be addressed.
- **Fix:** `npm audit` suggests a downgrade to `[email protected]` which is likely incorrect or a major regression. Recommendation is to wait for `serve` to update its dependency or use an override if urgent.
### Protocol / Critical (Manual Review Required)
* **nostr-tools**
* Current: `2.19.4`
* Wanted: `2.23.1`
* Latest: `2.23.1`
* **Action:** Requires manual review and testing of NIP compliance before upgrade.
## Outdated Packages
### Safe Candidates (Minor/Patch)
* **stylelint**
* Current: `16.12.0`
* Wanted: `16.26.1`
* Latest: `17.3.0`
* **Action:** Safe to upgrade to `16.26.1` in next cycle.
* **prettier-plugin-tailwindcss**
* Current: `0.6.14`
* Wanted: `0.6.14` (Wait, latest is 0.7.2)
* **Action:** Minor update available to 0.7.2.
| Package | Current | Wanted | Latest | Type | Action |
|---------|---------|--------|--------|------|--------|
| `nostr-tools` | 2.19.4 | 2.23.1 | 2.23.1 | dep | **SKIP** (Crypto/Protocol - requires manual review) |
| `stylelint` | 16.12.0 | 16.26.1 | 17.3.0 | devDep | **UPGRADE** (Safe minor bump to 16.26.1) |
| `pixelmatch` | 5.3.0 | 5.3.0 | 7.1.0 | devDep | Skip (Major) |
| `postcss-import` | 15.1.0 | 15.1.0 | 16.1.1 | devDep | Skip (Major) |
| `prettier-plugin-tailwindcss` | 0.6.14 | 0.6.14 | 0.7.2 | devDep | Skip (Potential breaking) |
| `stylelint-config-standard` | 36.0.1 | 36.0.1 | 40.0.0 | devDep | Skip (Major) |
| `tailwindcss` | 3.4.19 | 3.4.19 | 4.1.18 | dep | Skip (Major) |
### Major Upgrades (Breaking Changes)
* **tailwindcss**
* Current: `3.4.19`
* Latest: `4.1.18`
* **Action:** Major migration required (v3 -> v4). Create a dedicated task.
* **stylelint-config-standard**
* Current: `36.0.1`
* Latest: `40.0.0`
* **Action:** Major update.
* **pixelmatch**
* Current: `5.3.0`
* Latest: `7.1.0`
* **Action:** Major update.
* **postcss-import**
* Current: `15.1.0`
* Latest: `16.1.1`
* **Action:** Major update.
## 3. Recommendations
1. **High Priority**: Monitor `serve` for updates that bump `ajv`.
2. **Maintenance**: Schedule upgrade for `stylelint` (minor).
3. **Refactor**: Plan `tailwindcss` v4 migration.
## Upgrade Plan
- **Package:** `stylelint`
- **From:** `16.12.0`
- **To:** `16.26.1`
- **Reason:** Routine maintenance, keeping dev tools current.
- **Verification:** Run `npm run lint:css` and `npm run test:unit`.