chore(deps): deps-security-agent execution 2026-02-16

Co-authored-by: PR0M3TH3AN <[email protected]>
This commit is contained in:
google-labs-jules[bot]andPR0M3TH3AN committed 2026-02-16 12:54:06 +00:00
1 parent 33486ab9b5
commit cfd134443a
9 files changed
+11085 -112

No files matched your search

+23 -21
View File
@@ -1,26 +1,28 @@
# Dependency Security Report: 2026-02-14
# Dependency Audit Report
## Summary
- **Vulnerabilities**: 0
- **Outdated Packages**: 7
- **Critical/High Issues**: 0
## 1. Vulnerability Summary
- Total Vulnerabilities: 0
- Critical: 0
- High: 0
- Moderate: 0
- Low: 0
## Vulnerabilities
No known vulnerabilities found.
No vulnerabilities found.
## Outdated Packages
## 2. Outdated Packages
### Safe Upgrades (Patch/Minor)
- **jsdom** (dependencies): 28.0.0 -> 28.1.0 (Latest: 28.1.0)
- **stylelint** (dependencies): 16.12.0 -> 16.26.1 (Latest: 17.3.0)
| Package | Current | Wanted | Latest | Type | Status |
|---------|---------|--------|--------|------|--------|
| `nostr-tools` | 2.19.4 | 2.23.1 | 2.23.1 | dep | **REQUIRES REVIEW** (Crypto) |
| `stylelint` | 16.12.0 | 16.26.1 | 17.3.0 | devDep | Safe Candidate |
| `pixelmatch` | 5.3.0 | 5.3.0 | 7.1.0 | devDep | Major |
| `postcss-import` | 15.1.0 | 15.1.0 | 16.1.1 | devDep | Major |
| `prettier-plugin-tailwindcss` | 0.6.14 | 0.6.14 | 0.7.2 | devDep | Major/Minor |
| `stylelint-config-standard` | 36.0.1 | 36.0.1 | 40.0.0 | devDep | Major |
| `tailwindcss` | 3.4.19 | 3.4.19 | 4.1.18 | devDep | Major |
### Major Upgrades (Risky)
- **pixelmatch** (dependencies): 5.3.0 -> 7.1.0
- **postcss-import** (dependencies): 15.1.0 -> 16.1.1
- **prettier-plugin-tailwindcss** (dependencies): 0.6.14 -> 0.7.2
- **stylelint-config-standard** (dependencies): 36.0.1 -> 40.0.0
- **tailwindcss** (dependencies): 3.4.19 -> 4.1.18
## Recommendations
1. **nostr-tools**: Open an issue to review the changes in 2.23.1 and verify NIP compatibility.
2. **stylelint**: Safe to upgrade to 16.26.1.
3. **tailwindcss**: Plan migration to v4.
### Security/Protocol Libraries (Manual Review Required)
- **nostr-tools** (dependencies): 2.19.4 -> 2.23.1 (Latest: 2.23.1)
## 3. Recommendations
- **Action Item**: Attempt safe upgrade of `jsdom` from `28.0.0` to `28.1.0`.
+7
View File
@@ -1,4 +1,11 @@
{
"jsdom": {
"current": "28.0.0",
"wanted": "28.1.0",
"latest": "28.1.0",
"dependent": "app",
"location": "/app/node_modules/jsdom"
},
"nostr-tools": {
"current": "2.19.4",
"wanted": "2.23.1",